Bug #610

Enduro/X might hang a startup with advertise of empty xatmi service, issue when doing tpadvertise with empty service name

Added by Madars Vitolins 2 months ago. Updated about 2 months ago.

Status:ClosedStart date:11/26/2020
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:-
Target version:-

Description

Missing separate debuginfos, use: yum debuginfo-install endurox-7.5.6-1.el8.x86_64
(gdb) where
#0  0x00007f20a2747cbb in semop () from /lib64/libc.so.6
#1  0x00007f20a37510f8 in ndrx_sem_lock (sem=0x7f20a3e71520 <G_sem_svcop>, msg=0x429850 <__func__.14571> "brd_discconnected", sem_num=0) at /home/user1/endurox/libnstd/nstd_sem.c:177
#2  0x000000000041bf80 in brd_discconnected ()
#3  0x000000000041f78a in cmd_brdiscon ()
#4  0x000000000041180b in command_wait_and_run ()
#5  0x000000000040f0e6 in start_process ()
#6  0x0000000000410030 in app_startup ()
#7  0x0000000000412d81 in cmd_start ()
#8  0x000000000041180b in command_wait_and_run ()
#9  0x000000000040565e in main_loop ()
#10 0x0000000000405299 in main ()
(gdb) 

(gdb) thread apply all bt

Thread 1 (Thread 0x7f41eb3c6e80 (LWP 8108)):
#0  0x00007f41e946ccbb in semop () from /lib64/libc.so.6
#1  0x00007f41e9ce50f8 in ndrx_sem_lock (sem=sem@entry=0x7f41ea405520 <G_sem_svcop>, msg=msg@entry=0x7f41ea41d048 <__func__.9941> "sv_open_queue", sem_num=sem_num@entry=0) at /home/user1/endurox/libnstd/nstd_sem.c:177
#2  0x00007f41ea1817c1 in ndrx_lock_svc_op (msg=msg@entry=0x7f41ea41d048 <__func__.9941> "sv_open_queue") at /home/user1/endurox/libatmi/sem.c:192
#3  0x00007f41ea40b44d in sv_open_queue () at /home/user1/endurox/libatmisrv/svqdispatch.c:138
#4  0x00007f41ea4177b9 in ndrx_main (argc=9, argv=0x7ffd37bd8618) at /home/user1/endurox/libatmisrv/srvmain.c:1039
#5  0x0000000000404e14 in main ()
(gdb) 

N:NDRX:3:b9752097:08095:7f20a42868c0:000:20201126:123946570584:drx_sem_lock:td_sem.c:0177:brd_discconnected: Interrupted while waiting for semaphore!!

N:NDRX:5:b9752097:08097:7fde49ffb700:007:20201126:124026222484:ric_q_send_2:iutils.c:0323:ndrx_generic_q_send_2: 184
N:NDRX:5:b9752097:08097:7fde49ffb700:007:20201126:124026222701:neric_call_2:iutils.c:0600:Reply not needed!
N:NDRX:3:b9752097:08108:7f41eb3c6e80:001:20201126:124027954212:drx_sem_lock:td_sem.c:0177:sv_open_queue: Interrupted while waiting for semaphore!!
N:NDRX:3:b9752097:08097:7fde49ffb700:007:20201126:124031227565:et_addr_next:/exnet.c:1267:Reload addresses

History

#1 Updated by Madars Vitolins 2 months ago

  • Subject changed from tpbridge adding in xml as first server might stall the startup to Enduro/X might hang a startup with advertise of empty xatmi service

#2 Updated by Madars Vitolins 2 months ago

  • Subject changed from Enduro/X might hang a startup with advertise of empty xatmi service to Enduro/X might hang a startup with advertise of empty xatmi service, issue when doing tpadvertise with empty service name

#3 Updated by Madars Vitolins about 2 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

7.5+

#4 Updated by Madars Vitolins about 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF